WordPress post edit area is blank (displays white text on white background)

Wordpress Logo

Official WordPress Logo

Have you recently updated WordPress and then noticed that your post area looks blank when you edit existing posts or pages?

I noticed this after going through the hassle of upgrading to WordPress 3.3.1, and manifests itself as white text being displayed on a white background when your post edit page loads. You might also find that switching between ‘Visual’ and ‘HTML’ modes doesn’t work either, and the wysiwyg icons don’t display.

Having looked through loads of forums and support groups, with various suggestions such as uploading the WordPress files again, clearing cache, and switching off plugins, I came across a random suggestion that has appeared to fix the ‘white text on white background’ problem for me.

Try installing the Use Google Libraries plugin, then clear your browser cache and try again. If this works for you then it suggests a problem with one of the WordPress libraries or files in your install, as the plugin will go off to Google’s libraries to get the files it needs instead. This could also improve the performance of your site too, as you will be making use of Google’s content delivery network and it’ll reduce the load on your server too.

26 Responses to “WordPress post edit area is blank (displays white text on white background)”

  1. Website Design March 14, 2012 at 5:11 pm #

    What a strange bug. That would totally drive me bonkers. Normally WordPress is good about that stuff.

  2. Austin September 10, 2012 at 12:41 pm #

    Just encountered this bug today — The google libraries definitely helped out.

    Thanks

  3. heidi September 14, 2012 at 12:15 am #

    This did not work for me. I did the plugin install listed above. I updated WordPress today and now I have no Jetpack stats, and all of my edit post pages are blank.
    Like you said, in the HTML window, the content is still there. But I can’t do any editing in the visual window.
    I’m wondering if I should just restore from my latest backup?

  4. Martin Jarvis September 14, 2012 at 10:15 am #

    Heidi.
    I’m sorry this didn’t work for you. I don’t think you should revert to a backup version of your WordPress site just yet. There are many good reasons to keep your WordPress install bang up to date – including security, so let’s try to resolve the text editing issue for you first.

    1. You could have a plugin conflict – try de-activating each of your plugins in turn to see if your text editing area becomes visible again (start with the All-in-One SEO and User Access Manager plugins if you have either of those installed). If this is the problem, then make sure that plugin is up-to-date. If that still doesn’t resolve the problem then you might need to look for a replacement plugin.

    2. It could be an issue with your theme. Take a backup of your site and data and then try switching your theme back to the default WordPress theme – go to ‘Appearance’–>’Themes’ and activate the default theme – and see whether that resolves your edit problem. You should be able to switch between themes without impacting your site, but I have suggested backing up beforehand just in case!

    If either of those suggestions resolve the issue for you then please let us know. If it is not resolved then get in touch again and we’ll try to help out.
    Martin Jarvis recently posted..Why you shouldn’t align html justify

  5. Banana September 24, 2012 at 4:29 pm #

    Use Google Libraries plugin fixed it right away. Thanks!

  6. Graham September 24, 2012 at 4:31 pm #

    Thanks. This did the trick.

  7. Aaron October 19, 2012 at 4:36 pm #

    Ugh…another plugin issue. Mine was the wp auto responder newsletter plugin causing the blank screen on the post page. Solved! Thanks!

  8. Stefanie November 25, 2012 at 11:43 pm #

    thank you!!! use google library fixed it for me too. phew!

  9. aplc December 26, 2012 at 9:19 pm #

    Thx this solution help me to solve the problem!

  10. Greg December 29, 2012 at 3:05 am #

    The google library thing worked. Sadly, a ton of other stuff is buggy with the layout in the new WordPress update. What a colossal hassle. I can’t even add widgets I deactivated.

  11. Martin Jarvis December 29, 2012 at 9:03 pm #

    I’m glad you fixed the main problem.

    Have you just updated to WordPress 3.5? If you ping me (privately) your WordPress admin access details I’ll have a quick look to see if I can resolve your layout and widget problems. It could be that your theme, or one or more of your plugins, has yet to be updated for WordPress 3.5.
    Martin Jarvis recently posted..Do you password protect your WordPress posts or pages?

  12. Billfeld January 3, 2013 at 10:58 am #

    Really strange, but it elped for me. Thnx a lot! :-)

  13. Ajman January 4, 2013 at 8:37 pm #

    This is Genius !! the plugin suggested worked first time. Its take me 2 weeks of trying all sorts of fixes i found online.
    God Bless

  14. Kevin January 6, 2013 at 9:39 pm #

    Thanks for this tip. Totally fixed my error.

  15. Marcel Jansen January 18, 2013 at 1:31 am #

    Thanks a lot.

    After trying out a lot of tips that didn’t work, finally i found your solution to use the Google Library plugin and that worked for me.

    Marcel Jansen

  16. Jonathan January 21, 2013 at 8:36 pm #

    I can’t quite believe this worked, thanks so much – saved a lot of time!!!

  17. Julo February 3, 2013 at 8:24 pm #

    But how to solve this without plugin. I would say that it is really easy problem that can be set up somewhere in css

    • Martin Jarvis February 7, 2013 at 10:28 am #

      @Julo I don’t think this can be resolved with CSS changes, as it is a problem with the WordPress dashboard. I suspect that CSS changes (if they could be used) would need to be applied to the WordPress core code. these would then be overwritten the next time you upgrade your WordPress version.

      Whilst I don’t like using too many plugins in a website, as they can bloat an installation, there are times when they are a good idea. It also means that non-technical website owners can continue to maintain their website without needing to know any code.
      Martin Jarvis recently posted..Have you filled up your WordPress storage quota?

  18. Xyborg February 7, 2013 at 3:05 am #

    Thank you so much! Google Library plugin was the solution!

  19. Jo April 4, 2013 at 2:41 am #

    Thanks Martin
    You saved me hours!
    Jo

  20. Maartje April 11, 2013 at 10:17 am #

    Too bad. This does’nt work and makes the edit section dissappear totally untill I deactivate the use google library plug-in :((

    I use WordPress 3.5.1.
    This is a new install, no plug-ins except for the standard Askimet and Dolly.
    Just the standard themes.
    I’ve cleared the cache, I have deleted all wp files and did a re-install.
    Is there another solution?

  21. Big Birtha April 12, 2013 at 7:33 am #

    Hi, I’ve got this problem too – have had it over a week and it’s driving me bananas. My support thread on WordPress about it is here:

    http://wordpress.org/support/topic/edit-page-is-blank-site-not-displaying-properly-either-please-help?replies=20#post-4081771

    I’ve already tried removing all plug-ins (especially W3 Total Cache),and after reading this thread tried installing google libraries plug-in, but the edit page and post windows are still blank :(

    • Avic September 1, 2013 at 5:03 pm #

      Hi Big Bartha! This blank page screen to death in edit posts in wordpress just happened to me and sent me a hell of a panic.

      1. I tried deactivating all my plugins
      2. Revert my theme to the default theme.

      None of this solved the problem and not even google libraries plug-in helped me at all.

      But after hours of figuring it out, I was able to fix it. I turned out that the .htaccess rule was the source of the problem. To check this, I access my server thru ftp and rename the .htacess file. I clear cached and refresh the page and it works just fine for me.

      If this step did not solve the problem then it could be that your wordpress upgrade was not not performed properly and your files may be corrupted.

      I hope this could help you! =)

  22. Sam June 17, 2013 at 7:53 am #

    This worked for me after a week of frustration. Thanks!

  23. Galen September 5, 2013 at 9:31 am #

    Thank you!! Was still unable to switch between HTML View and WYSIWYG but it was enough to edit the page in HTML mode.

    Is it possible that this issue occurs when a page is too large? (i.e. full to the brim with text, images and links). I just had this issue with one page, which happened to be the largest by far…

    Thanks again :)

Leave a Reply

We're really pleased you want to comment. As a reward we'll include a link to one of your own blog posts. Write your comment as normal, then we'll display your recent blog posts for you to choose from. Un-check the box to opt out.